EdgeFromAlpha v1.3


 
This location is for Registered Users Only.
Perhaps you need to login or register.
Contributor: frank rueter
Website: www.ohufx.com
Simple edge generation tool based on dilating and eroding the alpha channel
Requirements:
6.1, 6.2, 6.3 or later
Linux, Mac, Windows
20 Jun 2011
1522

1.2 fixed the "nothing is named red" error

 


 

1.1 updated to avoid errors when unconnected

 


 

A simple edge tool that uses erodes and dilates to create an edge based on an incoming channel.

Please login in order to download these files.

Comments   

 
# David Schnee 2011-03-10 13:13
Hi Frank,

Do you know what's up with this error? I'm not sure why you are doing a copy of the incoming red channel into the edgeFromAlpha's red channel, then a Switch with the expression "parent.output == red". Why is this necessary?

ERROR: EdgeFromAlpha4. Switch1.which: Nothing is named "red"
using 6.1v3

Thanks,
-Schnee
 
 
# frank rueter 2011-03-10 13:56
Hi David,

the Copy nodes are required to provide the channel selection knobs in the UI. I've nowupdated this (rather old) gizmo to avoid the initial error hen it's unconnected.
Let me know if this works for you.

Cheers,
frank
 
 
# David Schnee 2011-03-10 16:04
I somehow completely blocked out those 2 gui channel controls in your gizmo... Duh, Winning. Thank you kindly for the update, will give it a shot as soon as things settle down around here. We have our own EdgeFromAlpha here, but shhh, I like yours better. :-)
 
 
# Prajakta Khatal 2011-06-01 04:40
Great upload!! very very useful.....than ks Frank! :-)
 
 
# Dushyant Kumar Kashyap 2011-06-19 11:06
Hey Frank, it still troughs error (ERROR: EdgeFromAlpha4. Switch1.which: Nothing is named "red") while opening the file(on console), and while firing the render on deadline (and the job always fails). People in my studio seriously like this gizmo of yours, but it's of no use coz they cannot render it on farm. Can you suggest any workaround.
 
 
# Frank Rueter 2011-06-19 16:16
I thought I fixed those problems. did you try the latest version?
 
 
# Frank Rueter 2011-06-19 16:24
btw, this version of EdgeFromAlpha doesn't even have a Switchj node inside it. Are you sure you don't have a different gizmo installed that is caled "EdgeFromAlpha" ?
 
 
# Dushyant Kumar Kashyap 2011-06-19 21:56
I downloaded it yesterday from this page, and yes it has a switch node inside :-) can you give me some alternate link, or please mail it to [email protected]

BTW: for the sake of cross-checking, I downloaded it once again before posting this comment, and opened it in text editor (don't have nuke here :-), and this is what it says...


Switch {
inputs 2
which {{"parent.outpu t == red"}}
name Switch1
xpos -191
ypos 456
}
 
 
# Frank Rueter 2011-06-20 02:20
ha, I apologize. I was the one looking at a different version. Will investigate...
 
 
# frank rueter 2011-06-20 02:31
ok, try v1.2
 
 
# Dushyant Kumar Kashyap 2011-06-20 03:12
Great!!! However I had to make a couple of changes
1. version 6.2 v3 to version 6.2 v2

2. We don't have a viewer Process Called DigiS so commented it.

You might also want to change it in your final release :-)

Cheers and many Thanks!
 
 
# Dushyant Kumar Kashyap 2011-06-20 03:14
Let's have a beer if you happen to drop in India!!!
 
 
# frank rueter 2011-06-20 03:21
Damn. that's what you get from trying to update stuff in the middle of a deadline. the viewer issue is fixed now. the version is what it is and doesn't hurt anyway (you can delete the version info from the gizmo's header if you want).
 
 
# Dushyant Kumar Kashyap 2011-06-20 03:32
Amazing, my day is saved anyway, thanks for quick Updates...
 

You have no rights to post comments

We have 3882 guests and 73 members online